シスコIOSコマンド一覧 | IT SKILL MAP

シスコIOSコマンド一覧

 IOSとはスイッチやルーターなどシスコ製品のハード内に組み込まれたシスコ独自OSのことを言います。
 ここではこのIOSの基本コマンド(CCNAレベル)について一覧でまとめます。

1.はじめに

 IOSでは、「モード」と呼ばれる、いわゆる階層的な概念があり、「モード」ごと入力できるコマンドが異なります。イメージは下図の通りです。

 現在どのモードにいるのかは、プロンプトの左側を見れば分かります。

 以下でこのモードごとに、使用できるコマンドをまとめています。
 なお、プロンプトの表記を簡素化するために、
 XX:共通
 SS:スイッチ
 RR:ルーター
 としています。

2.ユーザーモード

モード移行

XX>enable 特権モードへ (後にパスワード入力を求められる。)

3.特権モード

モード移行

XX#disableユーザーモードへ
XX#configure terminalグローバルコンフィグレーションモードへ

showコマンド

XX#show running-config現在動作中の全設定
XX#show startup-config次回IOS起動時に適用される全設定
XX#show versionIOSバージョン確認、コンフィグレーションレジスタ値の確認
XX#show file systemsファイルシステムの確認
XX#show flashフラッシュメモリの確認
XX#show interfaces <インターフェース> switchportスイッチポートの設定確認
XX#show sessionsリモートセッションの一覧表示
SS#show cdp neighborscdpの近隣表示
SS#show cdp neighbors detailcdpの近隣表示、近隣のIPアドレスまで判明
SS#show mac-address-tableマックアドレステーブル表示
SS#show vlan {brief}VLANの一覧表示
SS#show interfaces vlan <VLANID>VLANの設定確認
SS#show interfaces <インターフェース> trunkトランクの設定確認
SS#show interfaces statusインターフェースの状態確認
RR#show controllersシリアルインターフェースのDTE、DCE等確認
XX#show ip interfaceIP設定確認
XX#show ip interface briefIP設定確認 簡易表示
XX#show ip protocolsプロトコルの表示
RR#show ip nat translationsNATテーブル一覧表示
RR#show ip routeルーティング一覧表示
RR#show ip ospf OSPF状態確認
RR#show ip ospf interface <インターフェース> {brief}OSPF状態確認
RR#show ip ospf neighborネイバー関係を形成したOSPFルーターリスト
RR#show ip ospf databaseOSPFのLSDB表示
RR#show ip ospf costOSPFのパスコスト表示
RR#show ip dhcp conflictDHCPサーバーの衝突確認
RR#show vlansVLANの一覧表示(ルーター版)

※メモ:-- MORE -- と表示された場合、スペースキーで1画面送りします。

設定ファイル操作

XX#copy <元><先><例>
XX#copy running-config startup-config上書き:完全置換
XX#copy startup-config running-configマージ
XX#erase startup-config削除:初期化
XX#delete flash:vlan.dat削除:VLANデータベース
XX#reload再起動

リモートログイン

XX#telnet <IPアドレス|ホスト名>telnetリモート接続
XX#ssh <IPアドレス|ホスト名>sshリモート接続
XX#<shift+ctrl+6 → x>リモートセッションの中断
XX#resume <セッション番号>セッションの再開、セッション番号省略時は直近表示分
エンターでも可
XX#disconnect <セッション番号>セッションの切断、セッション番号省略時は直近表示分

4.グローバルコンフィグレーションモード

モード移行

XX(config)#interface <インターフェース番号>ポートインターフェースへ
XX(config)#line {console|con} 0コンソールアクセスへ
XX(config)#line vty 0 4リモートアクセスへ※この場合最大同時アクセス5セッション
SS(config)#interface vlan <VLAN番号>VLANインターフェースへ →管理IP設定
RR(config)#router ospf <プロセスID>OSPF設定へ
プロセスIDは1~65535の間で自由につけることができる
RR(config)#router ripRIP設定へ
RR(config)#ipv6 router rip <タグ>IPv6RIP設定へ
RR(config)#ipv6 router ospf <プロセスID>IPv6OSPF設定へ

共通

XX(config)#hostname <ホスト名>ホスト名の設定
XX(config)#username <ユーザー名> password <パスワード>ユーザーアカウントの作成
※CHAPの場合は対抗ルーター名をユーザー名にすること
XX(config)#config-register <コンフィグレーションレジスタ値>コンフィグレーションレジスタ値の設定
XX(config)#boot system {flash <ファイル名> | tftp <ファイル名> <サーバーIP> | rom}起動時にRAMに展開するIOSの元場所を指定
XX(config)#enable password <番号※省略可><パスワード>特権モードのパスワードセット:
show running-configでパスワード見える
番号は0~15。省略時15。0~14はユーザーEXEモード。
XX(config)#enable secret <番号※省略可><パスワード>特権モードのパスワードセット:
show running-configでパスワード見えない
番号は0~15。省略時15。0~14はユーザーEXEモード。
XX(config)#service password-encryptionパスワードを暗号化する
XX(config)#interface loopback <番号>仮想インターフェースの作成
番号は0~15。省略時15。0~14はユーザーEXEモード。

スイッチで使用

SS(config)#vlan <VLANID>VLANの作成 VLAN設定へ
SS(config)#mac-address-table static <マックアドレス> vlan <VLAN-ID> interface <インターフェースID>MACアドレステーブルにスタティックなエントリを追加
SS(config)#ip default-gateway <IPアドレス>デフォルトゲートウェイ設定

ルーターで使用

XX(config)#ip routingルーティング開始
XX(config)#ip subnet-zero0サブネットを有効化:デフォルト有効
RR(config)#ip route <ネットワークIP><サブネット> <ネクストIP> <オプション:AD> {permanent}スタティックルート作成
※ADアドミニストレーティブ値、指定しないとSTATICの「1」
RR(config)#ip route 0.0.0.0 0.0.0.0 <ネクストIP>デフォルトルート設定
RR(config)#ip nat inside source static <変換元IP><変換先IP>NATのスタティック変換
RR(config)#ip nat pool <プール名><開始IP><終了IP> prefix-length <ネットマスク EX. /24>NATアドレスプール
※prefix-lengthはnetmask<サブネットでも可>
RR(config)#ip nat inside source list <ACL番号 (変換元)><プール名 (変換先)>{overload}NATの変換設定
※overloadオプション付でPAT
RR(config)#ipv6 unicast-routingIPv6ルーティング有効化

5.インターフェースコンフィグレーションモード

共通

XX(config-if)#no shutdownインターフェース有効化
XX(config-if)#duplex <auto|full|half>全二重/半二重ネゴシエーション設定
XX(config-if)#speed <100 等MB単位>ポート速度
XX(config-if)#switchport port-securityポートセキュリティの有効化
XX(config-if)#switchport port-security mac-address <MACアドレス>ポートセキュリティ対象のMACアドレス登録:
セキュアMACアドレスとなる。
XX(config-if)#switchport port-security violation <protect|restrict|shutdown>バイオレーションの設定:デフォルトshutdown
XX#show port-securityポートセキュリティの確認

スイッチで使用

SS(config-if)#switchport port-security mac-address stickyセキュアMACアドレスをダイナミックに学習し、
running-configに反映させる。
SS(config-vlan)#name <VLANNAME>VLANの名前を設定する ※指定しないと全てのVLAN
SS(config-if)#ip address <IPアドレス><サブネット>IPアドレスの設定:管理用VLAN
SS(config-if)#switchport mode accessポートをアクセスにスタティックに設定
SS(config-if)#switchport mode trunkポートをトランクにスタティックに設定
SS(config-if)#switchport mode <dynamic desirable|dinamic auto>ポートをダイナミックに設定
SS(config-if)#switchport nonegotiateDTPを無効化
SS(config-if)#switchport access vlan <VLANID>アクセスポートをVLANに割り当てる
SS(config-if)#switchport trunk encapsulation <isl|dot1q|negotiate>トランクプロトコルを指定する:
ISLまたはIEEE802.1QまたはDTP
SS(config-if)#switchport trunk native vlan <VLANID>ネイティブVLANを設定する
SS(config-if)#switchport trunk allowd vlan <VLANLIST>VLANの範囲を設定する ※指定しないと全てのVLAN
※1-3,10,20等複数指定可
SS(config-if)#switchport trunk allowd vlan { add | all | except | remove}<VLANLIST>VLANの範囲を設定する ※指定しないと全てのVLAN
※1-3,10,20等複数指定可

ルーターで使用

RR(config-if)#encapsulation <isl|dot1q> <VLANID>トランクポートの設定
RR(config-if)#encapsulation <isl|dot1q> <VLANID> nativeネイティブトランクポートの設定
RR(config-if)#encapsulation <ppp|frame-relay|hdlc|atm>シリアルインターフェースの接続設定
RR(config-if)#ppp authentication <chap | pap | chap pap | pap chap>PPPの認証方式選択
RR(config-if)#ip address <IPアドレス><サブネット>IPアドレスの設定
RR(config-if)#ip helper-adress <DHCPサーバーのIPアドレス>DHCPの中継
RR(config-if)#ip nat <inside|outside>NATの設定
RR(config-router)#default-infomation originate他OSPFインターフェースにデフォルトルートをアドバタイズする
RR(config-if)#ip ospf priority <プライオリティ値 デフォ1 0から255 0は除外>OSPFのプライオリティ設定。大きい方がDR、BDRに選出。
RR(config-router)#router-id <ルーターID>ルーターIDを設定 ※省略すると最大IPがルーターID
RR#clear ip ospf processOSPFプロセスのリセット
RR(config-router)#network <ネットワークIP><ワイルドカード> area <AREA-ID>OSPFの有効化 ※ルーター自身のネットワーク
RR(config-router)#auto-cost reference-bandwidth <帯域 Mbps ※デフォ100M>OSPFのコスト計算元変更
RR(config-if)#ip ospf cost <コスト Mbps>OSPFのコスト直接設定
ロードバランスの際、不等コストを等コストにするため使用。
RR(config-if)#ip ospf <プロセスID> area <エリアID>インターフェースでOSPF有効化 ※IOS12.3以降
RR(config-if)#ip ospf network <mode>OSPFモード設定 broadcast | nonbroadcast | point-to-multipoint | point-to-multipoint non-broadcast | point-to-point
RR(config-router)#neighbor <IPアドレス>OSPFのネイバー手動設定 ※NBMAの場合
RR(config-if)#ip ospf hello-interval <秒>Helloインターバルの変更
RR(config-if)#ip ospf dead-interval <秒>Deadインターバルの変更
RR(config-router)#network <ネットワークIP>RIPの有効化(RIPはクラスフルだから、ワイルドカードない)
RR(config-router)#passive-interface <インターフェース>RIP、OSPF、EIGRPのアップデートを指定したインターフェースから送らない
RR(config-router)#bandwidth <帯域(kbps)>帯域設定:OSPF、EIGRPのパスコスト設定
※実際の通信速度に影響なし
RR(config-if)#clock rate <クロックレート(bps)>クロックレート設定:シリアルインターフェース
RR(config-if)#ipv6 address <ipv6 IP>/<プレフィックス>IPv6アドレス設定
RR(config-if)#ipv6 address autoconfigIPv6アドレス自動設定

6.サブインターフェースコンフィグレーションモード

 省略します。

7.ラインコンフィグレーションモード

XX(config-line)#pasword <パスワード>パスワード設定
XX(config-line)#access-class <ACL> inアクセスコントロールリストを使用してlogin端末を制限
XX(config-line)#transport input all全ての接続方式を受け入れる※デフォルト
XX(config-line)#transport input sshssh接続を受け入れる
XX(config-line)#loginログインを有効化

8.モードをまたぐ連続したコマンド処理

~ACLの適用~

RR(config)#access-list <ACL番号> <permit|deny> <元IP> <ワイルドカード>番号付標準ACL作成:ACL番号は1~99、1300~1999
RR(config)#access-list <ACL番号> <permit|deny> <プロトコル> <IP元> <ワイルドカード> <先IP> <ワイルドカード> <オプション:eq 80等>番号付拡張ACL作成:ACL番号は100~199、2000~2699
RR#show ip access-listsACLの表示
RR(config-if)#ip access-group <ACL番号> <in|out>インターフェースにACL適用

~公開鍵生成~

XX(config)#ip domain-name <ドメイン名>ドメイン名設定
XX(config)#crypto key generate rsa公開鍵生成

~ローカル認証~

XX(config)#username <ユーザー名> password <パスワード>ユーザー名パスワード設定
XX(config)#line vty 0 4リモートアクセスへ ※この場合最大同時アクセス5セッション
XX(config-line)#login localユーザー名とパスワードの認証を行う

~STPの設定~

SS#show spanning-tree [vlan <VLANID>] [detail]スパニングツリーの確認
SS#show spanning-tree rootスパニングツリールートブリッジのVLANごと確認
SS#show spanning-tree <インターフェース>スパニングツリーのポート状態をVLANごと確認
SS#show spanning-tree summaryグローバルなportfastを確認
SS(config)#spanning-tree vlan <VLANID>スパニングツリー有効化
※無効化は no spanning-tree vlan <VLANID>
SS(config)#spanning-tree <VLANID> priority <プライオリティ>スタティックなルートブリッジの設定
※プライオリティデフォルトは32768
SS(config)#spanning-tree <VLANID> root primaryダイナミックなルートブリッジの設定
SS(config)#spanning-tree <VLANID> root secondaryダイナミックなセカンダリルートブリッジの設定
SS(config)#spanning-tree portfast defaultすべてのポート上でportfastを有効化 ※アクセスポートのみ
SS(config)#spanning-tree portfast bpdugurd defaultすべてのportfastポートでBPDUガードを有効化
SS(config)#spanning-tree mode pvstPVST+の有効化
SS(config)#spanning-tree mode rapid-pvstPVRST+の有効化 (RSTPの有効化)
SS(config-if)#spanning-tree portfastポート上でportfastを有効化 ※エッジポートに設定
SS(config-if)#spanning-tree bpdugurd enableポート上でBPDUガードを有効化
※portfastでないポートにも設定可
SS(config-if)#spanning-tree uplinkfastアップリンクファストの設定

~EtherCannel~

XX#show etherchannel [summary]イーサチャンネルの確認
XX#show interfaces etherchannelイーサチャンネルの設定確認
XX#show etherchannel port-channelポートチャンネルの確認
XX#show port-channel load-balanceロードバランスの確認
XX(config)#interface range fastethernet 0/1-2レンジモードへ
XX(config-if-range)#channel-group <チャンネルグループNO> mode onスタティックなetherchannelの設定
XX(config-if-range)#channel-group <チャンネルグループNO> mode { active | passive }LACPモードの設定(ダイナミックなetherchannelの設定)
XX(config-if-range)#channel-group <チャンネルグループNO> mode { desirable [non-silent] | auto[non-silent] }PAgPモードの設定(ダイナミックなetherchannelの設定)
XX(config)#port-channel load-balance <method>EtherChannelのロードバランシング方法設定
methodはsrc-dst-mac、src-dst-ip等
XX(config)#interface port-cannel <チャンネルグループNO>設定したポートチャンネルインターフェースコンフィグレーションモードへ

~VTP~

SS#show vtp statusVTPの状態確認
SS#show vtp passwordVTPのパスワード確認
SS(config)#vtp domain <ドメイン名>VTPのドメイン名設定
SS(config)#vtp mode <server | client | transparent | off>VTPのモード設定 ※デフォルト サーバー
SS(config)#vtp password <パスワード>VTPのパスワード設定
SS(config)#vtp pruningVTPのプーリング有効化(サーバーモードの1台に)
SS(config)#vtp version <1 | 2 | 3>VTPのバージョン ※デフォルト1
※1は1~1001、2は1002~1005、3は1006~4094

~SNMPの設定~

XX#show snmpSNMPの設定確認
XX(config)#snmp-server cmmunity <SNMPコミュニティ名> [view <VIEW名>] [ro|rw] [<acl>]SNMPコミュニティストリングの設定
XX(config)#snmp-server host <ホストIP> [version {1|2c|3}] [auth|noauth|priv] <SNMPコミュニティ名>SNMPトラップの設定
XX(config)#snmp-server enable traps <トラップタイプ>SNMPトラップのトラップタイプ指定

~SYSLOGの設定~

XX#show loggingSYSLOGの設定確認
XX(config)#logging facirty <ファシリティタイプ>SYSLOGのファシリティタイプ変更 ※デフォルトはlocal7
XX(config)#no logging consoleコンソールにログ表示しない ※デフォルトは表示する
XX(config)#logging consoleコンソールにログ表示する
XX#terminal monitorVTY回線へのログ表示
XX(config)#logging <サーバーIP | サーバー名>SYSLOGサーバー設定
XX(config)#logging trap<シビリティ値 0~7>出力するログのシビリティ値設定
※設定値以下の出力となる。
XX(config)#logging buffered [<サイズ>] [<シビリティ値>]ログを内部バッファに保存
※サイズのデフォルトは4096バイト
XX(config)#service timestamps log [uptime | datetime] [localtime]ログタイムスタンプの設定

~NetFlowの設定~

XX#show ip flow interfaceインターフェースに対するNetFlowの設定を確認
XX#show ip flow exportNetFlowデータエクスポートの確認
XX#show ip cache flowNetFlowで収集したキャッシュ情報を確認
XX(config)#ip cefCEFを有効化 ※デフォルト有効
※NetFlowを使用する際の必須要件です。
XX(config-if)#ip flow {ingress | egress}インターフェースでNetFlowを有効化
XX(config)#ip flow-export destination {<IPアドレス> | <ホスト名>} <ポート番号>NetFlowコレクタの設定
XX(config)#ip flow-export version { 1 | 5 | 9 }NetFlowデータエクスポートのバージョン設定

~フレームリレーの設定~

XX#show frame-relay lmiLMI情報の表示
XX#show frame-relay pvc <dlci>PVC情報の表示
XX#show frame-relay mapフレームリレーマップの表示
XX#debug frame-relay mapフレームリレーマップのデバッグ
XX#no debug allデバッグの終了
XX(config-if)#encapsulation frame-relay { [cisco] | ietf }カプセルタイプをフレームリレーに設定
※対抗が非シスコルーターの場合ietf
XX(config-if)#frame-relay lmi-type { cisco | ansi | q933a }LMIタイプの設定
XX(config-if)#[no] frame-relay inverse-arp <プロコトル><dlci>inverse ARPの無効、有効化
XX(config-if)#frame-relay map <プロコトル><アドレス><dlci> [broadcast] [ietf]スタティックマップの設定
XX(config-if)#no ip split-horizonスプリットホライズンの無効化(RIP)
XX(config-if)#no ip split-horizon eigrp <AS番号>スプリットホライズンの無効化(EIGRP)
XX(config)#interface <インターフェース名>.<サブインターフェース名> {point-to-point | multipoint}フレームリレーサブインターフェースの作成
XX(config-if)#frame-relay interface-dlci <dlci>サブインターフェースにDLCIを関連付

~GREトンネルの設定~

XX#show interfaces tunnel <トンネル番号>GREトンネルの検証
XX(config)#interface tunnel <トンネル番号>トンネルインターフェース作成
XX(config-if)#ip adress <IPアドレス><サブネット>トンネルのIPアドレス設定
XX(config-if)#tunnel souce <IPアドレス>GREトンネルの送信元IPアドレス設定
XX(config-if)#tunnel destination <IPアドレス>GREトンネルの送信先IPアドレス設定
XX(config-if)#tunnel mode gre ipトンネルモードをGREに設定 ※デフォルト

~スタティックルート設定一連処理~

RR(config)#ip route <ネットワークIP><サブネット> <ネクストIP> <オプション:AD> {permanent}スタティックルート設定
RR(config)#ip route 0.0.0.0 0.0.0.0 <ネクストIP>デフォルトゲートウェイ設定
#show ip route設定確認

~RIP設定一連処理~

RR(config)#router ripRIPプロセスの有効化
RR(config-router)#network <10.0.0.0 | 172.16.0.0 | 192.168.1.0>クラスフルなので、ナチュラルマスクを入れること
RR(config-router)#version 2RIPv2に設定 ※一例
RR(config-router)#no auto-summary自動集約無効
#show ip route設定確認

~EIGRP設定一連処理~

RR(config)#router eigrp <AS番号>EIGRPプロセスの有効化 AS番号は1~65535で指定
RR(config-router)#network <自ネットワーク><ワイルドカードマスク>EIGRPを有効化するインターフェースの指定
RR(config-router)#passive-interface { <インターフェース> | default }パッシブインターフェースの設定
※無駄なHELLO等パケット送信抑制
RR(config-router)#maximum-paths <1~32 デフォルト4>ロードバランシングの最大数を設定
※1でロードバランシングなし OSPFも同一
RR(config-router)#variance <倍数 1~128 デフォルト1>不等コストロードバランシングの設定
RR(config-router)#auto-summary自動集約有効
RR(config-router)#no auto-summary自動集約無効
#show running-config設定確認
#show ip protocols設定確認
#show ip eigrp neighbors設定確認
#show ip route設定確認
#show ip route eigrp設定確認
#show ip eigrp interfaces [detail]設定確認
#show ip eigrp topology [all-links]設定確認
#show ip eigrp traffic設定確認
#debug ip eigrp設定確認

~EIGRP認証設定一連処理~

RR(config)#key chain <キーチェーン名>キーチェーンの作成
RR(config-keychain)#key <キーID>キーIDの作成
RR(config-keychain-key)#key-string <パスワード>キー(パスワード)の作成
RR(config-keychain-key)#accept-lifetime { | infinite | duration 受信のライフタイム設定
RR(config-keychain-key)#send-lifetime { | infinite | duration 送信のライフタイム設定
RR(config-if)#ip authentication mode eigrp md5EIGRPのMD5認証有効化
RR(config-if)#ip authentication key-chain eigrp <キーチェーン名>キーチェーンの適用
#show key chain設定確認

~OSPF認証設定一連処理~

RR(config-if)#ip ospf authentication {message-digest | なし}OSPF認証有効化 インターフェース単位
RR(config-router)#area <エリアID> authentication {message-digest | なし}OSPF認証有効化 エリア単位
RR(config-if)#ip ospf authentication-key <パスワード>平文パスワード設定
RR(config-if)#ip ospf message-digest-key <キーID> md5 <パスワード>MD5パスワード


おすすめの関連記事

IOSのシミュレーション環境構築方法
IOSのシミュレーション環境を構築する方法をまとめました